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UNIT 1: Digital Documentation (Advanced) LibreOffice
Writer

Overview: Covers advanced LibreOffice Writer features — Styles, Images, Templates, Table of

Contents, and Mail Merge. Theory: 8 Marks | Practical: 5 Marks

Chapter 1: Introduction to Styles
A Style is a set of formats that you can apply to selected pages, text, frames, or other elements in a

document to quickly change their appearance. Instead of formatting individually, a style applies many

formats in one step.

5 Types of Styles in LibreOffice Writer:

Term Description

Paragraph Style

Controls alignment, tab stops, line spacing, borders of a

paragraph.

Character Style Affects selected text — font, size, bold, italic formatting.

Page Style

Controls margins, headers, footers, borders, backgrounds of a

page.

Frame Style Controls position, size, background and borders of frames.

List Style Applies numbering or bullet point formatting.

Opening Styles & Formatting Window:
• Press F11 (shortcut key)

• Click Format → Styles & Formatting

• Click the Styles icon in the Sidebar

Applying a Style:
• Step 1: Select the text/paragraph.

• Step 2: Press F11 to open the Styles window.

• Step 3: Double-click on the desired style to apply it.

Fill Format Mode:
Fill Format is a feature that copies formatting from one text to another quickly, without returning to the

Styles window each time. It works like a 'format painter'. Activate it from the Styles window, click source

text, then click target text.

Creating a New Custom Style:
• Step 1: Open Styles window (F11).



• Step 2: Right-click an existing style → select New.

• Step 3: Name the style and set formatting options.

• Step 4: Click OK to save.

Note: To update an existing style: Right-click the style → Update Style. Shortcut: F11 opens Styles window.

Chapter 2: Working with Images & Drawing Objects
LibreOffice Writer allows inserting and manipulating images, shapes, charts, and diagrams. A digital

image is represented in pixels.

Ways to Insert an Image:

Term Description

Image Dialog Box Insert → Image → From File. Standard/general procedure.

Drag and Drop Open file browser, drag the image into the document.

Copy and Paste

Copy image from elsewhere, place cursor in document, press

Ctrl+V.

Insert by Linking

Saves only the link (path) of image, not the image itself — saves

space.

Image Operations (via Image Toolbar):

Term Description

Resizing

Use sizing handles (corner squares) to increase/decrease image

size.

Cropping

Removes unwanted parts of the image. Available in Image

Toolbar.

Rotating Rotate image using the rotation handle in LibreOffice Writer.

Grouping

Groups multiple objects into one — Format → Group. Does not

affect size/position.

Positioning Controlled by 4 settings: Horizontal, Vertical, Wrap, and Anchor.

Image Filters in LibreOffice Writer (12 filters):

Term Description

Invert Negates/inverts colors of the image

Smooth Softens contrast of the image



Sharpen Increases/sharpens contrast of the image

Remove Noise Removes single pixels (noise) from the image

Aging Produces a gray-scale, aged look

Posterize Reduces color depth

Pop Art Changes colors in a pop-art style

Charcoal Sketch Converts to charcoal-like sketch

Relief Creates embossed effect

Mosaic Pixelates the image

Solarization Partially inverts colors

Watercolor Gives a watercolor painting effect

Drawing Objects:
• To display the Drawing Toolbar: View → Toolbars → Drawing.

• Click and drag to create shapes, flowcharts, callout boxes, lines, etc.

• Drawing objects are different from images — they are created inside Writer.

Note: Insert by Linking saves the path of the image, NOT the image itself. If the image file is moved, the link

will break. Best used when same image appears multiple times.

Chapter 3: Advanced Features of Writer
3A. Templates
A Template is a predefined layout containing sample content, themes, colours, font styles, and

backgrounds. It provides an initial foundation to create a document quickly.

Term Description

Template extension .ott (LibreOffice Writer) | .dotx or .dot (MS Word)

Use case

Create business letters, reports, invoices without formatting from

scratch.

Using a Template:
• Step 1: File → New.

• Step 2: Click on Installed Templates in the dialog.

• Step 3: Select the template → Click Create.

3B. Table of Contents (TOC)



A Table of Contents is an organized listing of the document's chapters and sections with page numbers.

LibreOffice Writer creates it automatically from headings.

• Writer supports 10 heading levels: Heading 1 to Heading 10.

• Heading 1 = top-level; Heading 2, 3... = sub-levels.

• Path to insert TOC: Insert → Table of Contents & Index → Table of Contents.

• Structure line buttons: E# (chapter number), E (entry text), T (tab stop), # (page number).

3C. Mail Merge
Mail Merge is a feature used to send personalized letters/emails to multiple people by combining a

document template with a data source (like a spreadsheet).

Term Description

Document Area

Template file — holds the message and merge field

placeholders.

Data Source Data file (e.g., Calc spreadsheet) with names, addresses, etc.

F4 Key

Opens the database/datasource window for mail merge in

Writer.

Labels

Name & address info printed on envelopes/letters for each

recipient.

.ott file

Template file extension used in mail merge as the document

area.

Steps for Mail Merge:
• Step 1: Create the main document (letter) in Writer.

• Step 2: Connect to a data source (Calc spreadsheet with recipient data).

• Step 3: Insert merge fields (e.g., <<Name>>, <<Address>>) in the template.

• Step 4: Preview merge results.

• Step 5: Print or save as individual documents.

Note: F4 key opens the database window while implementing Mail Merge in Writer. Mail Merge CANNOT be

performed in LibreOffice Calc — only in Writer.

Important Shortcut Keys — LibreOffice Writer

Term Description

F11 Open Styles & Formatting window

F4 Open database window (for Mail Merge)

Ctrl + S Save the document



Ctrl + Z / Y Undo / Redo

Ctrl + C / V Copy / Paste

Ctrl + P Print document

Ctrl + F Find & Replace

Insert → Image Insert an image

Insert → TOC Insert Table of Contents

Format → Group Group selected drawing objects



UNIT 2: Electronic Spreadsheet (Advanced) LibreOffice
Calc

Overview: Covers advanced LibreOffice Calc — Consolidate, Subtotals, Scenarios, Goal Seek, Macros,

Linking Data, Sharing and Reviewing Spreadsheets. Theory: 10 Marks | Practical: 5 Marks

File Extension: .ods  |  Calc can: Store data, perform calculations, create charts, analyse data, link data,

share & review.

Chapter 4: Analyse Data — Consolidate, Subtotals, Scenarios & Goal Seek
4A. Consolidate
Consolidate combines data from multiple sheets/ranges into one master sheet to summarize information.

Supports SUM, AVERAGE, COUNT, MAX, MIN, etc. Default function is SUM.

• Path: Data → Consolidate

• 'Link to source data' — if checked, target sheet updates when source changes.

• Can consolidate by row/column labels (category-wise).

• Useful for merging data from multiple branches/departments.

4B. Subtotals
Subtotal automatically groups data and applies summary functions on categories. It creates a hierarchical

outline of the data.

• Path: Data → Subtotals

• Creates groups automatically (no manual grouping needed).

• Can sort data in Ascending or Descending order.

• Handles up to 3 arrays in labelled columns.

• Click – (minus) to collapse (hide); + (plus) to expand data.

• Remove outline: Data → Group and Outline → Remove Outline.

4C. Scenarios (What-If Analysis)
A Scenario is a set of values that Calc substitutes in cells to perform what-if analysis. Create multiple

scenarios (e.g., Best Case, Worst Case) and switch between them to compare results.

• Path: Tools → Scenarios

• Each scenario stores different values for a set of input cells.

• Multiple scenarios can exist in one spreadsheet.

• Used to compare different possible outcomes for the same formula.

4D. Goal Seek
Goal Seek works backwards — you set a desired result for a formula and it finds the input value needed

to achieve that result.

• Path: Tools → Goal Seek



• Example: Profit = Revenue - Cost. Set desired Profit = 50,000 → Goal Seek finds Revenue needed.

• Changes only ONE variable (input cell) at a time.

• Goal Seek is part of the What-If Analysis toolkit.

Scenarios vs Goal Seek — Comparison:

<b>Feature</b> <b>Scenarios</b> <b>Goal Seek</b>

Purpose Compare multiple sets of values Find input for a desired output

Variables Multiple input cells Single input cell only

Direction Forward (input → output) Backward (output → input)

Path Tools → Scenarios Tools → Goal Seek

Chapter 5: Using Macros in Spreadsheet
A Macro is a sequence of recorded actions (keystrokes, clicks, commands) that can be replayed

automatically. Macros save time by automating repetitive tasks. LibreOffice uses LibreOffice Basic as its

macro programming language.

Enabling Macro Recording:
• Path: Tools → Options → LibreOffice → Advanced

• Check 'Enable Macro Recording' option.

• Check 'Enable Basic IDE' option.

• Both must be enabled before recording.

Recording a Macro:
• Step 1: Tools → Macros → Record Macro.

• Step 2: Perform the actions you want to automate.

• Step 3: Click Stop Recording.

• Step 4: Name and save the macro in the dialog.

Running a Macro:
Path: Tools → Macros → Run Macro → Select macro → Click Run.

Actions that CANNOT be recorded in a Macro:
• Transferring actions between two different windows.

• Mouse-based selections (only keyboard selections are recorded).

• Drag-and-drop actions.

Macro as a Custom Function:
A macro written in LibreOffice Basic can be used as a custom function in Calc cells, just like built-in

functions (SUM, AVERAGE). This lets you define new functions beyond the defaults.



Where Macros are Stored:
• In the current document only

• In a user-defined macro library

• Globally (shared across all LibreOffice documents)

Note: Macros work in Calc, Writer, and can read Excel files. Always be cautious of security risks when

running macros from unknown sources. LibreOffice Basic is the programming language for Macros.

Chapter 6: Linking Spreadsheet Data
LibreOffice Calc allows creating links between cells across different sheets (within same file) or across

different files/documents.

Types of Hyperlinks:

Term Description

Internet Hyperlink Links to a website URL. e.g., https://www.cbse.nic.in

Mail Hyperlink Links to an email address (mailto:example@mail.com).

Document Hyperlink

Links to another document or a specific location within a

document.

New Document Link Creates a new document and links to it.

Absolute Hyperlink Contains full path/URL — works regardless of file location.

Relative Hyperlink

Contains path relative to current file — may break if file is

moved.

Inserting a Hyperlink:
• Path: Insert → Hyperlink

• Dialog opens with: Internet, Mail & News, Document, New Document options.

• Use Absolute hyperlinks when file location may change.

• Use Relative hyperlinks when files are always kept together.

Sheet Reference Formula (Linking Across Sheets):
Syntax: SheetName.CellAddress

Example: =Sheet2.B5 refers to cell B5 in Sheet2 of the same file.

Chapter 7: Share and Review a Spreadsheet
7A. Sharing a Spreadsheet:
LibreOffice Calc allows multiple users to work on the same spreadsheet simultaneously.

• Path: Tools → Share Document



• A dialog appears to activate or disable sharing.

• Multiple users can edit the file at the same time when sharing is ON.

• File must be saved in a shared/network location for others to access.

7B. Record Changes (Track Changes):
The Record Changes feature tracks and highlights all edits made by any user in the spreadsheet.

• Path: Edit → Track Changes → Record Changes

• All changes are highlighted/marked in the document.

• You can Accept or Reject each tracked change.

• Useful in collaborative/multi-user editing.

7C. Merging and Comparing Spreadsheets:
To compare two workbooks and track differences line by line, use the Spreadsheet Compare feature.

LibreOffice Calc allows merging changes from multiple copies of the same spreadsheet.

• Used when the same spreadsheet was sent to multiple reviewers.

• Merging combines all their changes into one file.

• Comparing shows differences between two versions side by side.

Important Shortcut Keys & Quick Reference — LibreOffice Calc

Term Description

Ctrl + S Save the spreadsheet

Ctrl + Z / Y Undo / Redo

Ctrl + Home Go to cell A1

Ctrl + End Go to last used cell

F4 Toggle absolute/relative cell reference

Ctrl + Shift + Enter Enter an array formula

Data → Consolidate Combine data from multiple sheets

Data → Subtotals Create automatic subtotals/grouping

Tools → Scenarios Create/manage What-If scenarios

Tools → Goal Seek Find input value for desired result

Tools → Macros → Record Start recording a macro

Tools → Share Document Enable multi-user sharing

Edit → Track Changes Enable record changes feature



Insert → Hyperlink Insert a hyperlink in the cell

.ods File extension for LibreOffice Calc spreadsheet

Quick Revision — Important File Extensions

Term Description

.odt LibreOffice Writer document

.ott LibreOffice Writer template

.ods LibreOffice Calc spreadsheet

.odb LibreOffice Base database

.odg LibreOffice Draw document

.odp LibreOffice Impress presentation

Note: Mail merge operation — CANNOT be performed in Calc (.ods). It is done in Writer (.odt). Macro

language used in LibreOffice is LibreOffice Basic. Default Consolidate function is SUM.


